找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 1308|回复: 29
打印 上一主题 下一主题
收起左侧

关于LMC7660IN+TL062CP运算放大器实际应用中的问题

[复制链接]
跳转到指定楼层
楼主
上图这个运算放大器电路中,我设计的是放大6倍,放大倍数就是R1/R2,但是在实际应用中发现,输入0.73V的信号时,输出是3.96V,实际放大了5.4倍,输入0.45V时,输出是4.23V,实际放大了9.4倍,这两个都不是6倍,请教各位高手,这是哪里的问题呢?该图中使用的运放是TL062CP,负电源发生器使用的是LMC7660IN.

运放.jpg (56.32 KB, 下载次数: 65)

运放.jpg
分享到:  QQ好友和群QQ好友和群 QQ空间QQ空间 腾讯微博腾讯微博 腾讯朋友腾讯朋友
收藏收藏1 分享淘帖 顶1 踩
回复

使用道具 举报

沙发
ID:446775 发表于 2021-8-6 18:39 | 显示全部楼层
其中放大部分主要是由TL062CPU1A完成的,U1B主要负责导相。
回复

使用道具 举报

板凳
ID:446775 发表于 2021-8-6 21:11 | 显示全部楼层
xuyaqi 发表于 2021-8-6 19:58
输出太接近电源电压造成失真,提高电源电压或减小输入。

输出也不算太接近电源电压。
回复

使用道具 举报

地板
ID:446775 发表于 2021-8-6 21:23 | 显示全部楼层
DS12C887 发表于 2021-8-6 19:22
1,非理想运放,会有吸收电流和漏电流,线性度也会受影响,你可以用ICL7650试试,效果会好很多
2,放大器输出电 ...

我用的电阻精度是1%的,这个精度还不能满足需求吗?不知道换上0.1%的会不会好一点,输出也不是太接近电源电压,电源电压我才用的是+5V的,输入信号0.7的话,如果放大6倍是4.2V,而实际只有3.96V,这是不是被限幅了呢?那输入0.45V的话,放大6倍应该是2.7V,但实际却是4.23V,又大了很多,这又是为什么呢?我再把电源电压提高至9V或者12V试一下
回复

使用道具 举报

5#
ID:446775 发表于 2021-8-6 22:20 | 显示全部楼层
Y_G_G 发表于 2021-8-6 21:31
这问题部得.....
1,运放的正负电压正常吗?有用示波器看过吗?万用表测量和示波器测量可是不一样的
2,我没 ...

放大的是直流信号,频率1K,最终输出指的是经TL062CP的U1B倒相后由7脚输出
回复

使用道具 举报

6#
ID:446775 发表于 2021-8-6 22:24 | 显示全部楼层
Y_G_G 发表于 2021-8-6 21:31
这问题部得.....
1,运放的正负电压正常吗?有用示波器看过吗?万用表测量和示波器测量可是不一样的
2,我没 ...

用的不是104,正电源用的是100uf,负电源用的是10uf,在电路板上是靠近电源引脚的,测量的时候是用夹子夹的
回复

使用道具 举报

7#
ID:446775 发表于 2021-8-9 20:55 | 显示全部楼层
lfc315 发表于 2021-8-9 17:47
前1级放大6倍,后1级放大了2倍,不是放大了12倍嘛;
输入信号源是什么,信号源内阻多大?
用什么测量的, ...

前一级放大6倍,后一级没有放大,输入的信号源是1Khz的矩形波,辐值0.6v,一开始用万用表测量的,但是不对,得用示波器看,用示波器看的时候发现这个TL062CP在电源电压低于6V时就不正常了,只有频率放大了6倍,而幅值没有被放大。不知道是怎么回事?
回复

使用道具 举报

8#
ID:446775 发表于 2021-8-9 21:00 | 显示全部楼层
Y_G_G 发表于 2021-8-7 09:54
建议:
1,在正负电源靠近运放的引脚处,加两个104电容,越近越好,有条件可以加一个102电容,104是必需的,不要 ...

您好,我发现我开始用万用表测量是不对的,又用示波器看了一下,发现TL062CP的电源电压在低于6V时只把频率放大了6倍,比如是1Khz的,它放大成6Khz,但是幅值没有变化,还有就是比如输入信号的幅值是0.4V左右,它只有在电源电压是8V左右时才是正常放大6倍的,是2.4V,但是它在这个电源电压时最大输出也是2.4V,就是说在这个电源电压是8V的情况下,我输入其它幅值的,比如0.7V,它输出幅值还是2.4V,这明显是不对的。。
回复

使用道具 举报

9#
ID:446775 发表于 2021-8-10 23:21 | 显示全部楼层
Y_G_G 发表于 2021-8-9 23:40
这压根就不是什么有多困难的电路呀,如果是我,我可以两个小时就找出问题来,并不是说我有多能,而是这个问题 ...

上次给您回复的时候两个104已经按照您说的加上了,也试了使用直流信号,在电源电压是6V左右时,是没有放大的,电源电压在8V左右时是有放大的,具体的放大倍数不同的信号电平,它的放大倍数也不一样
回复

使用道具 举报

10#
ID:446775 发表于 2021-8-10 23:25 | 显示全部楼层
lfc315 发表于 2021-8-10 18:42
哈,看来确实是我脑子糊涂了。。。
看了下,好像这个运放特性就是差不多这样的,输出信号要低于正电源4V ...

信号峰值0.8V和1.4V,它在正电源6V时都不起作用,只有正电源8V左右,才对峰值0.8V有放大作用,能够达到6倍的放大,但是对于峰值1.4V,也有放大作用,但是它的最大放大不能够达到6倍。
回复

使用道具 举报

11#
ID:446775 发表于 2021-8-10 23:27 | 显示全部楼层
lfc315 发表于 2021-8-10 18:42
哈,看来确实是我脑子糊涂了。。。
看了下,好像这个运放特性就是差不多这样的,输出信号要低于正电源4V ...

我实际用示波器看的话,对于0.4V的信号,正电源在8V左右就可以满足要求,但是正电源在6V时,这个放大器就不起作用了。
回复

使用道具 举报

12#
ID:446775 发表于 2021-8-11 19:18 | 显示全部楼层
lfc315 发表于 2021-8-11 09:22
在第一级输入端,0.4V的信号是没有问题的;
但是放大之后到第二级输入端,信号就超过了芯片的允许范围了 ...

不是的,现在是输入0.4V,然后第一级输出的是0.5V多点,就这第一级输出就不对,所以问题应该还是出在第一级,光看电路的话是没有多大的问题,我再找找是不是PCB的问题
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|小黑屋|51黑电子论坛 |51黑电子论坛6群 QQ 管理员QQ:125739409;技术交流QQ群281945664

Powered by 单片机教程网

快速回复 返回顶部 返回列表