单片机论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 7851|回复: 25
收起左侧

1602液晶显示一排方块

  [复制链接]
晨曦的love 发表于 2015-10-6 16:50 | 显示全部楼层 |阅读模式
    为什么1602液晶上电之后是这个样子,有一排显示方块,而不是背光显示,烧写程序之后也是这个样子,液晶对比调节了也还是这样,大神帮个忙啊!!!!!!

上电之后和烧写程序之后都是这个样子

上电之后和烧写程序之后都是这个样子
回复

使用道具 举报

cqqwing 发表于 2018-6-12 10:43 | 显示全部楼层
今天随手拿了块开发板来用,也是点亮1602以后,和这个图片一样,一排方块,检查了很久,不服气,程序我自认为是没问题的,结果找了很久的毛病,居然开发板的电路是错的,D0-D7的数据口是乱接的,果断刀片割开,焊锡烙铁改正线路,现在能显示出字了,但是遇到新问题,第二排光标能慢慢跳过去,就是不现实内容, 又迷茫了。

评分

参与人数 1黑币 +40 收起 理由
admin + 40 回帖助人的奖励!

查看全部评分

回复

使用道具 举报

zyc523161 发表于 2015-10-6 18:57 来自手机 | 显示全部楼层
个人感觉对比度还是太高,很长时间不用了,仅供参考。
回复

使用道具 举报

 楼主| 晨曦的love 发表于 2015-10-6 19:40 | 显示全部楼层
zyc523161 发表于 2015-10-6 18:57
个人感觉对比度还是太高,很长时间不用了,仅供参考。

调了对比度,但还是没有反应,还有其他什么原因么??
回复

使用道具 举报

admin 发表于 2015-10-6 20:14 来自手机 | 显示全部楼层
这个问题我也遇到过是接触不良导致了,建议重新焊接一下
回复

使用道具 举报

go21 发表于 2015-10-6 20:53 | 显示全部楼层
103调太低了,我一般调中间,这种问题要用替换法慢慢解决
回复

使用道具 举报

PLA 发表于 2015-10-8 14:16 | 显示全部楼层
本帖最后由 PLA 于 2015-10-8 14:18 编辑

程序可能有问题!检查一下程序!
回复

使用道具 举报

tjl974954407 发表于 2015-10-8 16:25 | 显示全部楼层
这是正常状态啊  你输入程序之后就会显示出来
回复

使用道具 举报

 楼主| 晨曦的love 发表于 2015-10-9 15:59 | 显示全部楼层
已经解决了。。。。
回复

使用道具 举报

admin 发表于 2015-10-9 23:59 来自手机 | 显示全部楼层
晨曦的love 发表于 2015-10-9 15:59
已经解决了。。。。

楼主怎么解决的能不能分享一下
回复

使用道具 举报

zouzoukankan 发表于 2015-10-10 10:04 | 显示全部楼层
去调节对比度,这是通病
回复

使用道具 举报

 楼主| 晨曦的love 发表于 2015-10-10 12:36 | 显示全部楼层
admin 发表于 2015-10-9 23:59
楼主怎么解决的能不能分享一下

      液晶的使用手册上的电气连接跟开发板上的连接有点差别,所以程序写的就有点问题,另外调了一下对比度,于是就解决了,非常感谢各位论坛朋友的帮助。。。。
回复

使用道具 举报

蜕变 发表于 2017-5-19 12:04 | 显示全部楼层
我也遇到了这个问题 之前没接电位器可以显示 但不能调对比度 现在接了电位器可以调对比度了 可死活不显示数据 只显示一排方格
回复

使用道具 举报

小白帆 发表于 2018-5-16 18:00 来自手机 | 显示全部楼层
晨曦的love 发表于 2015-10-9 15:59
已经解决了。。。。

请问你是这么解决的呢?
回复

使用道具 举报

小白帆 发表于 2018-5-16 18:01 来自手机 | 显示全部楼层
蜕变 发表于 2017-5-19 12:04
我也遇到了这个问题 之前没接电位器可以显示 但不能调对比度 现在接了电位器可以调对比度了 可死活不显示数 ...

同问,我调到分压最大了,也不会显示,一直都是方块
回复

使用道具 举报

小米不加糖 发表于 2018-5-16 21:02 | 显示全部楼层
对比度可能还有问题,要么就是引脚不对
回复

使用道具 举报

abcarry 发表于 2018-5-16 21:20 | 显示全部楼层
检查看看你的位定义
回复

使用道具 举报

0999kaysar 发表于 2018-6-5 00:21 来自手机 | 显示全部楼层
我也是这个问题啊。。。
回复

使用道具 举报

hk0506 发表于 2018-6-5 14:18 | 显示全部楼层
这个问题遇到过,接触不良,拔下来重新插一下也可以。或者是程序问题了,端口不对应。
回复

使用道具 举报

1205693382 发表于 2018-6-12 15:09 | 显示全部楼层
接触不良   重新安装焊接
回复

使用道具 举报

546100166 发表于 2018-6-12 19:32 | 显示全部楼层
仔细看看是不是焊接问题
回复

使用道具 举报

君子慎独 发表于 2019-1-12 15:32 | 显示全部楼层
cqqwing 发表于 2018-6-12 10:43
今天随手拿了块开发板来用,也是点亮1602以后,和这个图片一样,一排方块,检查了很久,不服气,程序我自认 ...

震惊!改一下程序引脚定义就能解决的问题,竟然去修改PCB电路,服气
回复

使用道具 举报

累不死的狗 发表于 2019-1-12 21:21 | 显示全部楼层
程序的问题,指令写的不对
回复

使用道具 举报

这一生只为你 发表于 2019-1-13 13:08 | 显示全部楼层
1602接好电源,调好对比度就是这样,没有显示内容要么就是程序的问题要么就是引脚接线的问题
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|单片机论坛 |51黑电子论坛单片机. 联系QQ:125739409;技术交流QQ群582644647

Powered by 单片机教程网

快速回复 返回顶部 返回列表